summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDanilo Bargen2016-03-17 22:40:22 +0100
committerDanilo Bargen2016-03-17 22:40:22 +0100
commit8450d57efd9aed19bca985297d7b0b3d10166d99 (patch)
tree6c2f828ad53a5768e62420c179abf2dbbe4527d9 /PKGBUILD
downloadaur-8450d57efd9aed19bca985297d7b0b3d10166d99.tar.gz
Version 1.0.0b1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55716c3d36e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Danilo Bargen aur ât dbrgn döt ch
+pkgname=upscrot
+pkgver=1.0.0b1
+pkgrel=1
+_wheel="${pkgname}-${pkgver}-py3-none-any.whl"
+pkgdesc="Take a screenshot using the Linux scrot command and upload it directly to your SSH server."
+arch=('i686' 'x86_64')
+url="https://github.com/dbrgn/$pkgname"
+license=('GPL')
+makedepends=('python' 'python-setuptools' 'python-pip')
+depends=('python'
+ 'python-appdirs'
+ 'scrot')
+provides=('upscrot')
+conflicts=('upscrot')
+noextract=(${_wheel})
+source=("https://pypi.python.org/packages/py3/u/${pkgname}/${_wheel}")
+sha256sums=('100a8b34ec4b5cd8218d97d2a3bf2361a54710a3117f3f5441ede2085c6148e2')
+
+package() {
+ cd "$srcdir"
+ pip install --root "$pkgdir" $_wheel
+}