summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaksym2018-01-07 01:50:30 +0200
committerMaksym2018-01-07 01:50:30 +0200
commita70c6a812a443765d374aef7be739c800587e991 (patch)
tree79ce5fc9b59e5caf2c0c7032e6588ff87f24c00e /PKGBUILD
parent4ca5de7dd4112d4c6ee83c2d476c6a5697e9460d (diff)
downloadaur-a70c6a812a443765d374aef7be739c800587e991.tar.gz
Update to upstream version 5.0.1.404.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD61
1 files changed, 32 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b57650739525..ba40d211ee64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,48 +2,51 @@
# Maintainer: Maksym Sheremet <msheremet at sheremets dot com>
pkgname=upwork
-pkgver=4.2.153.0
+pkgver=5.0.1.404
_rawver=${pkgver//./_}
-_hashver="tkzkho5lhz15j08q"
-pkgrel=3
+_hashver="e83l5wbauyxiky5x"
+pkgrel=1
pkgdesc="Desktop App (aka Team App) Standard version"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://www.upwork.com/downloads?source=Footer"
license=('custom')
conflicts=('upwork-alpha' 'upwork-appimage' 'upwork-beta')
-depends=('alsa-lib' 'gconf' 'gtkglext' 'libgcrypt15' 'libxss' 'libxtst' 'nss')
-makedepends=('git' 'gtk-doc') # needed to build pango
+#depends=('alsa-lib' 'gconf' 'gtkglext' 'libgcrypt15' 'libxss' 'libxtst' 'nss')
+depends=('alsa-lib' 'gconf' 'gdk-pixbuf2' 'gtk2' 'libxss' 'libxtst' 'nss')
+#makedepends=('git' 'gtk-doc') # needed to build pango
install=upwork.install
-source=("LICENSE" "git+https://git.gnome.org/browse/pango#commit=6c5d1d35061a91c3c0792f7720da3f8308ebff65")
-md5sums=('1a87c2b530067bcf4c632e49c18af484' 'SKIP')
-md5sums_i686=('fa3aa945068e49081e1ac2cc7490032b')
-md5sums_x86_64=('6c33e3ff5ae168c840f46887d690fd5e')
+#source=("LICENSE" "git+https://git.gnome.org/browse/pango#commit=6c5d1d35061a91c3c0792f7720da3f8308ebff65")
+source=("LICENSE")
+#md5sums=('1a87c2b530067bcf4c632e49c18af484' 'SKIP')
+md5sums=('1a87c2b530067bcf4c632e49c18af484')
+#md5sums_i686=('fa3aa945068e49081e1ac2cc7490032b')
+md5sums_x86_64=('2edecdec8b26797057f6633b99fc2ab6')
# how to get links Standard, Beta, Alpha: grep "https://updates-desktopapp.upwork.com/binaries" ~/.Upwork/Upwork/Logs/* | tail -n 4
-source_x86_64=(upwork_amd64_${pkgver}.deb::https://updates-desktopapp.upwork.com/binaries/v${_rawver}_${_hashver}/upwork_amd64.deb)
-source_i686=(upwork_i386_${pkgver}.deb::https://updates-desktopapp.upwork.com/binaries/v${_rawver}_${_hashver}/upwork_i386.deb)
+source_x86_64=(upwork_${pkgver}_amd64.deb::https://updates-desktopapp.upwork.com/binaries/v${_rawver}_${_hashver}/upwork_${pkgver}_amd64.deb)
+#source_i686=(upwork_i386_${pkgver}.deb::https://updates-desktopapp.upwork.com/binaries/v${_rawver}_${_hashver}/upwork_i386.deb)
prepare() {
cd "${srcdir}"
- tar -zxf "${srcdir}/data.tar.gz"
+ tar -xJf "${srcdir}/data.tar.xz"
### BEGIN pango section ###
- cd pango
- NOCONFIGURE=1 ./autogen.sh
+# cd pango
+# NOCONFIGURE=1 ./autogen.sh
### END pango section ###
}
### BEGIN pango section ###
-build() {
- cd "${srcdir}/pango"
- ./configure --prefix=/usr
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
-}
-
-check() {
- cd "${srcdir}/pango"
- make -k check || :
-}
+#build() {
+# cd "${srcdir}/pango"
+# ./configure --prefix=/usr
+# sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+# make
+#}
+#
+#check() {
+# cd "${srcdir}/pango"
+# make -k check || :
+#}
### END pango section ###
package() {
@@ -52,8 +55,8 @@ package() {
install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
### BEGIN pango section ###
- install -Dm755 "${srcdir}/pango/pango/.libs/libpangoft2-1.0.so.0.4000.5" \
- "${pkgdir}/usr/share/upwork/libpangoft2-1.0.so.0.4000.5"
- ln -s "libpangoft2-1.0.so.0.4000.5" "${pkgdir}/usr/share/upwork/libpangoft2-1.0.so.0"
+# install -Dm755 "${srcdir}/pango/pango/.libs/libpangoft2-1.0.so.0.4000.5" \
+# "${pkgdir}/usr/share/upwork/libpangoft2-1.0.so.0.4000.5"
+# ln -s "libpangoft2-1.0.so.0.4000.5" "${pkgdir}/usr/share/upwork/libpangoft2-1.0.so.0"
### END pango section ###
}