summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12017-08-22 15:52:38 +0800
committerChocobo12017-08-22 16:09:58 +0800
commit3efe0a6cadaef70c5bde1ba4129059a0b7a3961e (patch)
tree3a39f52d9b2becc210c5bea5abf9e00c7a18a652 /PKGBUILD
downloadaur-3efe0a6cadaef70c5bde1ba4129059a0b7a3961e.tar.gz
newpkg: upx-git 3.94.r80.g5b545444-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f7b6d106e743
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=upx-git
+pkgver=3.94.r80.g5b545444
+pkgrel=1
+pkgdesc="A free, portable, extendable, high-performance executable packer for several executable formats"
+arch=('i686' 'x86_64')
+url="https://upx.github.io/"
+license=('GPL2')
+depends=('glibc' 'ucl' 'zlib')
+makedepends=('git')
+provides=('upx')
+conflicts=('upx')
+source=("git+https://github.com/upx/upx.git#branch=devel")
+sha256sums=('SKIP')
+
+
+prepare() {
+ cd "upx"
+
+ git submodule update --init --recursive --depth 1
+}
+
+pkgver() {
+ cd "upx"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "upx"
+
+ make all
+}
+
+package() {
+ cd "upx"
+
+ install -Dm755 "src/upx.out" "$pkgdir/usr/bin/upx"
+ install -Dm644 "doc/upx.1" "$pkgdir/usr/share/man/man1/upx.1"
+}