summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12023-04-06 05:32:55 +0800
committerChocobo12023-04-06 05:32:55 +0800
commitae5f0a95ee68b08dca2a6a259331b562513ba82d (patch)
tree304f005ad3e8f47056a5dca39848c0b80c699971 /PKGBUILD
parente05d173f1e794d9cb5495b18cd462737de24cce1 (diff)
downloadaur-ae5f0a95ee68b08dca2a6a259331b562513ba82d.tar.gz
upgpkg: upx-git 4.0.2.r13.g15484aa2-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9dccb0731c52..e490f94d8d83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=upx-git
-pkgver=3.94.r143.g7a0514d9
+pkgver=4.0.2.r13.g15484aa2
pkgrel=1
pkgdesc="A free, portable, extendable, high-performance executable packer for several executable formats"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="https://upx.github.io/"
license=('GPL2')
depends=('gcc-libs' 'ucl' 'zlib')
makedepends=('git')
-provides=('upx')
+provides=("upx=$pkgver")
conflicts=('upx')
source=("git+https://github.com/upx/upx.git#branch=devel")
sha256sums=('SKIP')
@@ -18,7 +18,7 @@ sha256sums=('SKIP')
prepare() {
cd "upx"
- git submodule update --init --recursive --depth 1
+ git submodule update --init --recursive
}
pkgver() {
@@ -37,5 +37,5 @@ package() {
cd "upx"
install -Dm755 "src/upx.out" "$pkgdir/usr/bin/upx"
- install -Dm644 "doc/upx.1" "$pkgdir/usr/share/man/man1/upx.1"
+ install -Dm644 "doc/upx.1" -t "$pkgdir/usr/share/man/man1"
}