summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVale Cofer-Shabica2017-09-25 11:49:22 -0400
committerVale Cofer-Shabica2017-09-25 11:49:22 -0400
commit0171673278edb95add48026e80603e551324c9c6 (patch)
tree0ec393dbd4d62e2d6343e8bab37e92efd529e543 /PKGBUILD
parent8172a37ab1640f59e035f6c48c4ffcb528e0cc5d (diff)
downloadaur-0171673278edb95add48026e80603e551324c9c6.tar.gz
simplified install and map update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dd8b19b43aed..ec91acf089c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
# Maintainer: Robert Kubosz <kubosz.robert@gmail.com>
+# Contributor: Vale Cofer-Shabica <vale.cofershabica@gmail.com>
pkgname=urw-classico
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc='URW Classico font from CTAN (for texlive)'
arch=('any')
license=('CUSTOM:alladin')
url='http://www.ctan.org/pkg/urw-classico'
depends=('texlive-core')
install=$pkgname.install
-source=('http://mirror.ctan.org/fonts/urw/classico.zip'
+source=('http://mirrors.ctan.org/install/fonts/urw/classico.tds.zip'
'license')
-md5sums=('e8ce4a2c293ffe386bf5800e0f9f89df'
- '330cccd8a2978150e99c5e20926af5f3')
+noextract=('classico.tds.zip')
+md5sums=('166eb8e7f2e1ca764b02e00aae5e86fb'
+ '7689a58e80bcc8546b76e397b83a572b')
package() {
cd "$srcdir"
- texmf_root=usr/share/texmf/tex/latex
- mkdir -p "$pkgdir/$texmf_root/classico"
- cp -r classico "$pkgdir/$texmf_root"
+ texmf_root=usr/share/texmf
+ mkdir -p "$pkgdir/$texmf_root"
+ bsdtar -xf $srcdir/classico.tds.zip -C "$pkgdir/$texmf_root"
+ chown -R 0:0 $pkgdir/$texmf_root
install -Dm644 $srcdir/license "$pkgdir/usr/share/licenses/$pkgname/license"
}