summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Löthberg2013-06-12 22:51:41 +0200
committerJohannes Löthberg2015-06-08 14:34:46 +0200
commitca866a3451b4be7e7de30d8484cb9cd7baf0d910 (patch)
treef4feb13a512d1fc7fcdabeb9fa45ec9592f82d9b /PKGBUILD
parentdfa83caa81e3875b245c0dedbe67a7bef46e8aa0 (diff)
downloadaur-ca866a3451b4be7e7de30d8484cb9cd7baf0d910.tar.gz
Updated urxvt-tabbdex-git PKGBUILD to use Pacman 4.1 VCS support and apply perl 5.18 patch
The PKGBUILD has been refactored to use the VCS support in pacman 4.1, to not do everything in build() and to apply yardenac's perl 5.18 patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 16 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21209c2d5f37..d641895586e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributor: M Rawash <mrawash@gmail.com>
pkgname="urxvt-tabbedex-git"
-pkgver=20120216
+pkgver=20130612
pkgrel=1
-pkgdesc="Tabbed plugin for rxvt-unicode with many enhancements, development version"
+pkgdesc="Tabbed plugin for rxvt-unicode with many enhancements, git version with perl 5.18 patch."
arch=("any")
url='http://github.com/stepb/urxvt-tabbedex'
license=("GPL")
@@ -12,22 +12,22 @@ depends=('rxvt-unicode')
makedepends=('git')
provides=('urxvt-tabbedex')
conflicts=('urxvt-tabbedex')
-install=${pkgname}.install
+install=urxvt-tabbedex-git.install
+source=('git://github.com/stepb/urxvt-tabbedex.git'
+ '0001-make-urxvt-tabbedex-work-with-perl-5.18.patch')
+md5sums=('SKIP'
+ '92d581a40779da3127c88fdc7d10257f')
-_gitroot="git://github.com/stepb/urxvt-tabbedex.git"
-_gitname="urxvt-tabbedex"
-
-build() {
- msg "Connecting to ${_gitroot}..."
+pkgver() {
+ date +%Y%m%d
+}
- if [ -d ${srcdir}/${_gitname} ] ; then
- cd ${srcdir}/${_gitname} && git pull origin master
- else
- git clone $_gitroot
- fi
+prepare() {
+ cd ${srcdir}/urxvt-tabbedex
- msg "GIT checkout done or server timeout"
- msg "Starting Installation..."
+ git apply ../0001-make-urxvt-tabbedex-work-with-perl-5.18.patch
+}
- install -Dm644 ${srcdir}/${_gitname}/tabbedex ${pkgdir}/usr/lib/urxvt/perl/tabbedex
+package() {
+ install -Dm644 ${srcdir}/urxvt-tabbedex/tabbedex ${pkgdir}/usr/lib/urxvt/perl/tabbedex
}