summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIan Beringer2016-08-09 00:50:51 +0200
committerIan Beringer2016-08-09 00:50:51 +0200
commit9ff84fcf181db77d903ba57bc3fc04d684ee713d (patch)
tree5dfb751659974586a97f01e7c50a9e5132f679aa /PKGBUILD
parent47ae8f7f63cf5ee594315091ce8f9e522b7739c2 (diff)
downloadaur-9ff84fcf181db77d903ba57bc3fc04d684ee713d.tar.gz
use recommended pattern for patching
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f05c724143a0..e22396e7bccc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,19 @@
pkgname=usbguard-git
_pkgname=usbguard
pkgver=0.5.10.66.gbf28a52
-pkgrel=1
+pkgrel=2
license=('GPL2')
pkgdesc='USBGuard is a software framework for implementing USB device authorization policies'
makedepends=("git" "libqb-git" "libsodium")
depends=()
arch=("i686" "x86_64")
url='https://github.com/dkopecek/usbguard'
-source=("${_pkgname}::git+https://github.com/dkopecek/usbguard.git")
-sha256sums=('SKIP')
+source=(
+ "${_pkgname}::git+https://github.com/dkopecek/usbguard.git"
+ "disable_json_regression_test.patch")
+sha256sums=(
+ 'SKIP'
+ '644ae1819eaf405091878bdcf78a5f71d7b344346c4e67a24525e4fb442eed4d')
provides=("usbguard")
pkgver() {
@@ -21,7 +25,7 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- git apply ../../disable_json_regression_test.patch
+ patch -p1 <../disable_json_regression_test.patch
./autogen.sh
./configure --prefix=/usr --sbindir=/usr/bin --libdir=/usr/lib \
--enable-systemd \