summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFaerbit2020-06-17 23:18:23 +0200
committerFaerbit2020-06-17 23:18:23 +0200
commitca5bf8fc6b184c743043f30b9704460b21e3d027 (patch)
treeb050bd1c6ddca6362f7ede4b5708be547f5eb292 /PKGBUILD
downloadaur-ca5bf8fc6b184c743043f30b9704460b21e3d027.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78338a45f760
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Faerbit <faerbit at gmail dot com>
+
+pkgname=usbguard-notifier
+pkgver=0.0.6
+pkgrel=1
+pkgdesc="A tool for detecting usbguard policy and device presence changes"
+arch=('x86_64')
+url="https://github.com/Cropi/usbguard-notifier"
+license=('GPL2')
+depends=('usbguard' 'libnotify' 'librsvg')
+makedepends=('catch2' 'asciidoc')
+source=("https://github.com/Cropi/usbguard-notifier/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"{,.asc})
+md5sums=('SKIP'
+ 'SKIP')
+
+validpgpkeys=('42363D1C30A574A4EE5D9C87E650CBBFEF3AAC4B') # alakatos at redhat dot com
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure CPPFLAGS=-I/usr/include/catch2 --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}