summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzhanghua0002021-12-04 17:05:26 +0800
committerzhanghua0002021-12-04 17:05:26 +0800
commit0f4bdae09ea63e0c56748fe9103d37c013b0f89c (patch)
treea12abc0c6ace4903d9a8ea0b4ef08d3f57ff0497 /PKGBUILD
downloadaur-0f4bdae09ea63e0c56748fe9103d37c013b0f89c.tar.gz
First Release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0edbacaf4f11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: ZhangHua <zhanghua.00@qq.com>
+# Contributor: Faerbit <faerbit at gmail dot com>
+
+pkgname=usbguard-notifier-git
+pkgver=0.0.6_6_gaf64a92
+pkgrel=1
+pkgdesc="A tool for detecting usbguard policy and device presence changes"
+arch=('x86_64')
+url="https://github.com/Cropi/usbguard-notifier"
+license=('GPL2')
+depends=('usbguard' 'libnotify' 'librsvg')
+makedepends=('catch2' 'asciidoc' 'git')
+source=("git+https://github.com/Cropi/usbguard-notifier")
+sha256sums=('SKIP')
+conflicts=('usbguard-notifier')
+provides=('usbguard-notifier')
+pkgver(){
+ cd "$srcdir/usbguard-notifier"
+ git describe --tags | sed "s/usbguard-notifier-//;s/-/_/g"
+}
+build() {
+ cd "$srcdir/usbguard-notifier"
+ ./autogen.sh
+ ./configure CPPFLAGS=-I/usr/include/catch2 --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/usbguard-notifier"
+ make DESTDIR="$pkgdir/" SYSTEMD_UNIT_DIR=/usr/lib/systemd/system/ install
+}