summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2015-09-26 17:28:06 +0200
committerNicolas Iooss2015-09-26 17:28:06 +0200
commitfee853125ac732fddb59a84da46bd2c273361374 (patch)
treedd9f04a35f13adf15a6a8b018f1e04f3e5235aad /PKGBUILD
downloadaur-fee853125ac732fddb59a84da46bd2c273361374.tar.gz
Import ustr-1.0.4-4 and fix build with gcc 5.2
This library is used by libsemanage and therefore needs to be built with a recent gcc.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bcc6b0cbe62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 100295 2013-11-02 08:51:09Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+
+pkgname=ustr-selinux
+pkgver=1.0.4
+pkgrel=4
+pkgdesc="micro string API for C with patches to make it work with gcc>=5.1"
+arch=(i686 x86_64)
+url="http://www.and.org/ustr/"
+license=('GPL')
+depends=('glibc')
+conflicts=("${pkgname/-selinux}")
+provides=("${pkgname/-selinux}=${pkgver}-${pkgrel}")
+source=(http://www.and.org/ustr/$pkgver/ustr-$pkgver.tar.bz2
+ 0001-Fix-the-prototype-of-ustrp_utf8_valid.patch
+ 0002-Mark-inline-functions-as-static-to-fix-build-with-GC.patch)
+md5sums=('93147d9f0c9765d4cd0f04f7e44bdfce'
+ 'd01d97898f4c3b33a87c06e602ca9409'
+ '9e7830ea74ff2f24f9b029746e883f3e')
+
+prepare() {
+ cd "$srcdir/${pkgname/-selinux}-$pkgver"
+ patch -Np1 -i ../0001-Fix-the-prototype-of-ustrp_utf8_valid.patch
+ patch -Np1 -i ../0002-Mark-inline-functions-as-static-to-fix-build-with-GC.patch
+}
+
+build() {
+ cd "$srcdir/${pkgname/-selinux}-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname/-selinux}-$pkgver"
+ make DESTDIR="$pkgdir" install
+ mv $pkgdir/usr/share/doc/man $pkgdir/usr/share/
+}