summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxim Devaev2024-04-07 18:12:36 +0300
committerMaxim Devaev2024-04-07 18:12:36 +0300
commit33c1fd94bf93011906762944c40ca5c301d9c86d (patch)
treec74d94744fc83bd6a81764845fe387b55de82c0f /PKGBUILD
parentd5a9d668d3008189d1917a85ca117c7e6deb1473 (diff)
downloadaur-ustreamer.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 2 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fe31cb0d86df..c19084395c43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ustreamer
-pkgver=6.4
+pkgver=6.11
pkgrel=1
pkgdesc="Lightweight and fast MJPEG-HTTP streamer"
url="https://github.com/pikvm/ustreamer"
@@ -19,7 +19,7 @@ _options="WITH_GPIO=1 WITH_SYSTEMD=1"
if [ -e /usr/bin/python3 ]; then
_options="$_options WITH_PYTHON=1"
depends+=(python)
- makedepends+=(python-setuptools)
+ makedepends+=(python-setuptools python-pip python-build python-wheel)
fi
if [ -e /usr/include/janus/plugins/plugin.h ];then
depends+=(janus-gateway alsa-lib opus)
@@ -28,12 +28,6 @@ if [ -e /usr/include/janus/plugins/plugin.h ];then
fi
-# LD does not link mmal with this option
-# This DOESN'T affect setup.py
-LDFLAGS="${LDFLAGS//--as-needed/}"
-export LDFLAGS="${LDFLAGS//,,/,}"
-
-
build() {
cd "$srcdir"
rm -rf $pkgname-build