summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTimothée Ravier2014-01-16 21:36:16 +0100
committerTimothée Ravier2014-01-16 21:36:16 +0100
commit13abb45108e0adc493c685ad42800644f8f33242 (patch)
tree65548d469fd9343404e5fe800606df42a9f06422 /PKGBUILD
parent49e3361b3eb11f955b1973eb5e7bb6490b097342 (diff)
downloadaur-13abb45108e0adc493c685ad42800644f8f33242.tar.gz
util-linux-selinux 2.24-2 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 21 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 766ff67142d8..81bd6e7b80a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,20 +7,25 @@
pkgname=util-linux-selinux
pkgver=2.24
-pkgrel=1
-pkgdesc="Miscellaneous system utilities for Linux"
-url='http://www.kernel.org/pub/linux/utils/util-linux/'
+pkgrel=2
+pkgdesc="SELinux aware miscellaneous system utilities for Linux"
+url="http://www.kernel.org/pub/linux/utils/util-linux/"
arch=('i686' 'x86_64')
groups=('selinux')
depends=('pam-selinux' 'shadow-selinux' 'coreutils' 'glibc' 'libselinux')
optdepends=('python: python bindings to libmount')
makedepends=('systemd' 'python')
# checkdepends=('bc')
-conflicts=('util-linux-ng' 'eject' "${pkgname/-selinux}" "selinux-${pkgname/-selinux}")
-provides=("util-linux-ng=$pkgver" 'eject' "${pkgname/-selinux}=${pkgver}-${pkrel}" "selinux-${pkgname/-selinux}=${pkgver}-${pkrel}")
+conflicts=('util-linux-ng' 'eject'
+ "${pkgname/-selinux}" "selinux-${pkgname/-selinux}")
+provides=("util-linux-ng=$pkgver" 'eject'
+ "${pkgname/-selinux}=${pkgver}-${pkrel}"
+ "selinux-${pkgname/-selinux}=${pkgver}-${pkrel}")
license=('GPL2')
options=('strip' 'debug')
source=("ftp://ftp.kernel.org/pub/linux/utils/${pkgname/-selinux}/v2.24/${pkgname/-selinux}-$pkgver.tar.xz"
+ 0001-lsblk-fix-D-segfault.patch
+ 0001-pylibmount-correctly-import-from-pylibmount.so.patch
uuidd.tmpfiles
pam-login
pam-common
@@ -32,11 +37,20 @@ backup=(etc/pam.d/chfn
etc/pam.d/su-l)
install=util-linux.install
md5sums=('4fac6443427f575fc5f3531a4ad2ca01'
+ '1899fe3b853a5835c76cca0501b6b518'
+ 'a18a1e89ffdfa3bc96ae976646a723ec'
'a39554bfd65cccfd8254bb46922f4a67'
'4368b3f98abd8a32662e094c54e7f9b1'
'a31374fef2cba0ca34dfc7078e2969e4'
'fa85e5cce5d723275b14365ba71a8aad')
+prepare() {
+ cd "${pkgname/-selinux}-$pkgver"
+
+ patch -Np1 <"$srcdir"/0001-lsblk-fix-D-segfault.patch
+ patch -Np1 <"$srcdir"/0001-pylibmount-correctly-import-from-pylibmount.so.patch
+}
+
build() {
cd "${pkgname/-selinux}-$pkgver"
@@ -52,8 +66,8 @@ build() {
--enable-write \
--enable-mesg \
--enable-socket-activation \
- --with-python=3 \
- --with-selinux
+ --with-selinux \
+ --with-python=3
# --enable-reset \ # part of ncurses
# --enable-last \ # not compat