summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2018-08-01 21:09:59 +0200
committerNicolas Iooss2018-08-01 21:09:59 +0200
commitedd2745e58fa1b69f1099f4e3cfa59c68e3a3ab0 (patch)
tree1570ba51a3b9672fd0c333018e9c6119d3c0d1fd /PKGBUILD
parente00b2974df5994a7e869539d92d715b727f68a75 (diff)
downloadaur-edd2745e58fa1b69f1099f4e3cfa59c68e3a3ab0.tar.gz
util-linux-selinux 2.32.1-1 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 7 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 08c835813ed8..e416ccc0dc2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,15 @@
# SELinux Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
# SELinux Contributor: Timothée Ravier <tim@siosm.fr>
# SELinux Contributor: Nicky726 <nicky726@gmail.com>
+#
+# This PKGBUILD is maintained on https://github.com/archlinuxhardened/selinux.
+# If you want to help keep it up to date, please open a Pull Request there.
pkgbase=util-linux-selinux
pkgname=(util-linux-selinux libutil-linux-selinux)
_pkgmajor=2.32
-pkgver=${_pkgmajor}
-pkgrel=3
+pkgver=${_pkgmajor}.1
+pkgrel=1
pkgdesc="SELinux aware miscellaneous system utilities for Linux"
url="https://www.kernel.org/pub/linux/utils/util-linux/"
arch=('x86_64')
@@ -22,20 +25,16 @@ groups=('selinux')
# util-linux-selinux depend on systemd at build time.
makedepends=('systemd' 'python' 'libcap-ng' 'libselinux')
license=('GPL2')
-options=('strip' 'debug')
+options=('strip')
validpgpkeys=('B0C64D14301CC6EFAEDF60E4E4B71D5EEC39C284') # Karel Zak
source=("https://www.kernel.org/pub/linux/utils/util-linux/v$_pkgmajor/${pkgbase/-selinux}-$pkgver.tar."{xz,sign}
- '0001-fstrim-cleanup-uncludes.patch'
- '0002-libmount_include_sys_mount_h_only_if_necessary.patch'
pam-{login,common,su}
'util-linux.sysusers'
'60-rfkill.rules'
'rfkill-unblock_.service'
'rfkill-block_.service')
-sha256sums=('6c7397abc764e32e8159c2e96042874a190303e77adceb4ac5bd502a272a4734'
+sha256sums=('86e6707a379c7ff5489c218cfaf1e3464b0b95acf7817db0bc5f179e356a67b2'
'SKIP'
- 'b1c0db069f60c086351f7a6fb7ff1add1c41e9ed7c1b65bd67e6604943fc4c75'
- 'c65d8354fc2773035be8ac071541f4709763366d22a8a8f1bc2cb3401dcfdf69'
'993a3096c2b113e6800f2abbd5d4233ebf1a97eef423990d3187d665d3490b92'
'fc6807842f92e9d3f792d6b64a0d5aad87995a279153ab228b1b2a64d9f32f20'
'51eac9c2a2f51ad3982bba35de9aac5510f1eeff432d2d63c6362e45d620afc0'
@@ -44,13 +43,6 @@ sha256sums=('6c7397abc764e32e8159c2e96042874a190303e77adceb4ac5bd502a272a4734'
'8ccec10a22523f6b9d55e0d6cbf91905a39881446710aa083e935e8073323376'
'a22e0a037e702170c7d88460cc9c9c2ab1d3e5c54a6985cd4a164ea7beff1b36')
-prepare() {
- cd "${pkgbase/-selinux}-$pkgver"
-
- patch -Np1 -i ../0001-fstrim-cleanup-uncludes.patch
- patch -Np1 -i ../0002-libmount_include_sys_mount_h_only_if_necessary.patch
-}
-
build() {
cd "${pkgbase/-selinux}-$pkgver"