summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052024-05-29 12:45:00 +0800
committerzxp198210052024-05-29 12:45:00 +0800
commit43e56cd617acedb55778d32f3b8d4c68cac24858 (patch)
treeebc64d1cdba71023c85245ef6e5050d3e24d985f /PKGBUILD
parent5063bfb5e0602bc052f1157b4e4db08c069fd01d (diff)
downloadaur-utilso-bin.tar.gz
fix errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index beae54b107ce..f914510290b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=utilso-bin
_pkgname=Utilso
pkgver=4.4.0
_electronversion=15
-pkgrel=7
+pkgrel=8
pkgdesc="Regex Tester, JWT Verify, Image Converter, Format JSON, Decode base64, Code Beautify and more.Work completely offline"
arch=("x86_64")
url="https://utilso.com"
@@ -11,7 +11,7 @@ license=("LicenseRef-custom")
provides=("${pkgname%-bin}")
conflicts=("${pkgname%-bin}")
depends=(
- "electron${_electronversion}-bin"
+ "electron${_electronversion}"
'nodejs'
)
makedepends=(
@@ -24,11 +24,12 @@ source=(
)
sha256sums=('3d26f15d7210f805f56d92f2d828844a0a16b789ec7e4f3a4983e50ae7d050cc'
'f76129e6cdc1748270f37acfdd278015789a888d2226b81531bccd58486df1e5'
- 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+ '2b2e8aeed33fd71c521e49fd54fb2fa81218d16aef8bccb88d77909055ab8051')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@cfgdirname@|${pkgname%-bin}|g" \
-e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"