summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKaizhao Zhang2018-11-22 22:24:57 +0800
committerKaizhao Zhang2018-11-22 22:24:57 +0800
commit5b1a75915464d34f208a0ff867e270c3cab01439 (patch)
tree95d1822190ee71f67cde18153cc1da505de6a5f2 /PKGBUILD
downloadaur-5b1a75915464d34f208a0ff867e270c3cab01439.tar.gz
Initial import
Note: the default HTTP parser implementation `httptools` packaged on AUR https://aur.archlinux.org/packages/python-httptools/ now is 0.0.9 which is incompatible with uvicorn now. Please use another HTTP parser implementation `h11` instead. See documentation of uvicorn.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e52666e5fb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
+
+pkgname=uvicorn
+pkgver=0.3.21
+pkgrel=1
+pkgdesc="The lightning-fast ASGI server."
+arch=('any')
+url="https://www.uvicorn.org/"
+license=('BSD')
+depends=('python>=3.5' 'python-click' 'python-h11'
+ 'python-httptools' 'python-uvloop' 'python-websockets>=6.0')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=("https://github.com/encode/uvicorn/archive/${pkgver}.tar.gz")
+sha256sums=('f333d74f94a4a82fb723ac19b207647f65269ee46dc3e31f7322f3fe6e176d6d')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+}