summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryayaduckd2024-05-26 15:41:10 +0200
committeryayaduckd2024-05-26 15:41:10 +0200
commit2f78a87e4449885e04a1d358d227e92847d63489 (patch)
treed0cd18e87fa386a6ebc9dff2dcb2da3da074d02c /PKGBUILD
downloadaur-2f78a87e4449885e04a1d358d227e92847d63489.tar.gz
aur package init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aada98c2268f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: yayaduckd <yayaduckd@proton.me>
+
+pkgname=uwaka-git
+_pkgname="${pkgname%-git}"
+pkgver=0.5.0
+pkgver() { git -C "$_pkgname" describe --tags | sed 's/^v//;s/-/.r/;s/-/./g'; }
+pkgrel=1
+pkgdesc="Universal Wakatime Client"
+arch=('x86_64' 'aarch64' 'i686')
+url="https://github.com/yayaduckd/$_pkgname"
+license=('MIT')
+makedepends=('git' 'zig')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url")
+sha256sums=('SKIP')
+
+execname="uwaka_$arch-linux"
+
+build() {
+ cd "$srcdir/$_pkgname"
+ zig build --release=small
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$_pkgname/README.md"
+ install -Dm755 "zig-out/bin/$execname" "$pkgdir/usr/bin/$_pkgname"
+}
+