summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorScore_Under2024-02-13 11:50:26 +0000
committerScore_Under2024-02-13 11:51:33 +0000
commit4cdc233e4b73bc974b69cf46a80f06911b3b1177 (patch)
treebd6f086dcdfbbb63cbc4740fc3f1caceca96e7fe /PKGBUILD
parentac7e684d470af26665c75cc98264681724b775e2 (diff)
downloadaur-4cdc233e4b73bc974b69cf46a80f06911b3b1177.tar.gz
Move patch into sources; replace with single file; ensure correct installed permissions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e56cfa92c68..274c9540112e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,21 @@
pkgbase=uwebsockets
pkgname=uwebsockets
pkgver=20.37.0
-pkgrel=2
+pkgrel=3
pkgdesc="Simple, secure & standards compliant web server for the most demanding of applications"
url="https://github.com/uNetworking/uWebSockets"
license=('Apache')
arch=('x86_64')
-source=( "$pkgname-$pkgver.tar.gz::https://github.com/uNetworking/uWebSockets/archive/v$pkgver.tar.gz" )
-md5sums=('1fdad53ba3bfea8d9b2bd460d92e6292')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/uNetworking/uWebSockets/archive/v$pkgver.tar.gz"
+ "uwebsockets.pc")
+sha256sums=('ea155453c056477a4650ca86c093712af79b19504b6522454331e74743d9bd37'
+ '5433dee099ea6f6fe97ef200cc19aadc71ca5066d7f5238070c25cd040dfb520')
depends=( usockets )
package() {
- cd "uWebSockets-$pkgver"
- patch < ../../uwebsockets-$pkgver-Makefile.patch
- mkdir -p "$pkgdir"/usr/include/uWebSockets
- cp -a src/. "$pkgdir"/usr/include/uWebSockets
- mkdir -p "$pkgdir"/usr/lib/pkgconfig
- cp uwebsockets.pc "$pkgdir"/usr/lib/pkgconfig/uwebsockets.pc
+ cd "$srcdir/uWebSockets-$pkgver"
+ install -Dm644 -t "$pkgdir"/usr/include/uWebSockets/ src/*.h
+ install -Dm644 "$srcdir"/uwebsockets.pc "$pkgdir"/usr/lib/pkgconfig/uwebsockets.pc
}
#vim: syntax=sh