summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlanthora2023-04-01 05:12:58 +0000
committerlanthora2023-04-01 05:12:58 +0000
commitac7e684d470af26665c75cc98264681724b775e2 (patch)
tree9c59d3c402f7a6cb7c0d3bb464b097ae2b8e3df1 /PKGBUILD
parent3ebf56b0a8acb1260cd2032201293c27782003eb (diff)
downloadaur-ac7e684d470af26665c75cc98264681724b775e2.tar.gz
add uwebsockets.pc
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 44f5ba6f6580..0e56cfa92c68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,22 @@
pkgbase=uwebsockets
pkgname=uwebsockets
pkgver=20.37.0
-pkgrel=1
+pkgrel=2
pkgdesc="Simple, secure & standards compliant web server for the most demanding of applications"
url="https://github.com/uNetworking/uWebSockets"
license=('Apache')
arch=('x86_64')
-source=( "${pkgname}-${pkgver}.tar.gz::https://github.com/uNetworking/uWebSockets/archive/v${pkgver}.tar.gz" )
+source=( "$pkgname-$pkgver.tar.gz::https://github.com/uNetworking/uWebSockets/archive/v$pkgver.tar.gz" )
md5sums=('1fdad53ba3bfea8d9b2bd460d92e6292')
depends=( usockets )
package() {
- cd "uWebSockets-${pkgver}"
- mkdir -p "${pkgdir}"/usr/include/uWebSockets
- cp -a src/. "${pkgdir}"/usr/include/uWebSockets
+ cd "uWebSockets-$pkgver"
+ patch < ../../uwebsockets-$pkgver-Makefile.patch
+ mkdir -p "$pkgdir"/usr/include/uWebSockets
+ cp -a src/. "$pkgdir"/usr/include/uWebSockets
+ mkdir -p "$pkgdir"/usr/lib/pkgconfig
+ cp uwebsockets.pc "$pkgdir"/usr/lib/pkgconfig/uwebsockets.pc
}
#vim: syntax=sh