summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLin Ruoshui2019-01-14 21:39:32 +0800
committerLin Ruoshui2019-01-14 21:39:32 +0800
commite08912d6ee51683c3cce7fdbe98516f01552e507 (patch)
tree4ab540ba52c401cedfb80255224a71e53cd8d78e /PKGBUILD
downloadaur-e08912d6ee51683c3cce7fdbe98516f01552e507.tar.gz
add package v2ray-plugin
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69ed82d52b0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor:
+
+pkgname=v2ray-plugin
+pkgver=20190114
+pkgrel=1
+pkgdesc='Yet another SIP003 plugin for shadowsocks, based on v2ray'
+arch=('x86_64')
+url='https://github.com/shadowsocks/v2ray-plugin'
+license=('MIT')
+#depends=('' '')
+makedepends=('go')
+conflicts=('v2ray-plugin-git')
+source=("https://github.com/shadowsocks/v2ray-plugin/releases/download/v$pkgver/v2ray-plugin-linux-amd64-$pkgver.tar.gz"
+ "https://github.com/shadowsocks/v2ray-plugin/blob/master/LICENSE")
+sha256sums=('c0b07d577e271738ac51e68ddeb3fc724adad645f09c92ecdc3ea97faaaeb74a'
+ '53092ce9ca01bb6941cbda1d5884e859f04f1a8aa246316db8bea1060e6f2c8e')
+package() {
+ install -Dm755 v2ray-plugin_linux_amd64 ${pkgdir}/usr/bin/v2ray-plugin
+ install -Dm755 LICENSE ${pkgdir}/usr/share/licenses/v2ray-plugin/LICENSE
+ echo "README FILE: https://github.com/shadowsocks/v2ray-plugin/blob/master/README.md"
+}