summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormzz20172019-11-22 03:11:41 +0800
committermzz20172019-11-22 03:11:41 +0800
commita99fe361c976c4e354e6f6a592a643d9576abfc2 (patch)
tree50bb9f2808bb4154c43b56172ce55d7a31ea7433 /PKGBUILD
parent11a282ab6c37a815686f2623cc62be4d64aa8cb7 (diff)
downloadaur-a99fe361c976c4e354e6f6a592a643d9576abfc2.tar.gz
AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 17 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 07e3eb107ad7..39bf7305f72a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ prepare() {
build() {
cd "V2RayA-$pkgver/service"
- go build -ldflags='-X V2RayA/global.Version=$pkgver' -o v2raya
+ go build -ldflags="-X V2RayA/global.Version=$pkgver" -o v2raya
}
package() {
@@ -27,3 +27,19 @@ package() {
install -Dm644 "install/v2raya.service" "$pkgdir/usr/lib/systemd/system/v2raya.service"
install -Dm755 "service/v2raya" -t "$pkgdir/usr/bin/"
}
+
+post_install() {
+ bash install/after_install.sh
+}
+
+post_remove() {
+ bash install/after_remove.sh
+}
+
+post_upgrade() {
+ bash install/after_upgrade.sh
+}
+
+pre_remove() {
+ bash install/before_remove.sh
+} \ No newline at end of file