summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTravis CI User2019-11-27 18:38:56 +0000
committerTravis CI User2019-11-27 18:38:56 +0000
commitb942fa1c7297baf981d17e857a792cfc59f16b8e (patch)
tree5b6047e91673a861e01a3d7b02d51a000d84cadc /PKGBUILD
parent303148cc3a437bac2ea1efed3f759a9676e12e45 (diff)
downloadaur-b942fa1c7297baf981d17e857a792cfc59f16b8e.tar.gz
AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61e06360a350..c97e6e77aa6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: mzz2017 <m@mzz.pub>
pkgname=v2raya
-pkgver=0.4.1
+pkgver=0.4.2
pkgrel=1
install=.INSTALL
pkgdesc="V2RayA是一个支持全局透明代理的V2Ray Linux客户端。"
@@ -13,13 +13,10 @@ makedepends=('go>=2:1.11.3-1')
source=("$pkgname-$pkgver.tar.gz::https://github.com/mzz2017/V2RayA/archive/v$pkgver.tar.gz")
sha512sums=('SKIP')
-prepare() {
- export GO111MODULE=on
- export GOPROXY=https://goproxy.io
-}
-
build() {
cd "V2RayA-$pkgver/service"
+ export GO111MODULE=on
+ export GOPROXY=https://goproxy.io
go build -ldflags="-X V2RayA/global.Version=$pkgver" -o v2raya
}