summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormzz20172021-08-26 13:11:42 +0000
committermzz20172021-08-26 13:11:42 +0000
commit8e0daa64face6afd252f29ae715b54f1a053f60f (patch)
tree3a240e0be1fbde4ec95b2b33a7332cf50cec133e /PKGBUILD
parent936e56e5bd201044ff97be0977ffd1f338ccf3c5 (diff)
downloadaur-8e0daa64face6afd252f29ae715b54f1a053f60f.tar.gz
release v1.5.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e02282aac6d6..18d7b584a227 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=v2raya-bin
_pkgname=v2raya
-pkgver=1.4.4
+pkgver=1.5.0
pkgrel=1
install=.INSTALL
pkgdesc="A web GUI client of Project V which supports VMess, VLESS, SS, SSR, Trojan and Pingtunnel protocols"
@@ -14,16 +14,16 @@ optdepends=('v2ray>=4.37.0-1' 'xray>=1.4.2-1')
provides=('v2raya')
conflicts=('v2raya')
-sha_service=ba580b203c1971780d2721a48fbc828d11467d5a
+sha_service=0fcd700dbd5aa409b13bff64e738e566fc996881
+sha_service_at=3fd341dde6e9a9d5ea828904042f9beb6028b289
sha_png=5c51b3e670733d6d1cf22e1cb5fe45305f4b8014
sha_desktop=f4abf270b2ce588a4e8ab4b5ccdc9168b96791fe
-sha_web=279d7ab251d830268555dea07360e6ce7383188a
source=(
"v2raya.service"
+ "v2raya@.service"
"v2raya.png"
"v2raya.desktop"
- "web_v${pkgver}.tar.gz::https://apt.v2raya.mzz.pub/pool/main/v/v2raya/web_v${pkgver}.tar.gz"
)
source_i686=(
@@ -44,33 +44,32 @@ source_armv7h=(
sha1sums=(
"$sha_service"
+ "$sha_service_at"
"$sha_png"
"$sha_desktop"
- "$sha_web"
)
sha1sums_i686=(
- '61aa149d526cb230112ef384bc7ce715d5946f10'
+ '81a8b628dd1bfeda01ba68d57b3359650e12596a'
)
sha1sums_x86_64=(
- '66a9608096f6edbd4612f198f88a2f13a9d882f4'
+ '4bec2ae30fa0c5a56bdb79b5eb55f070bdd8326f'
)
sha1sums_aarch64=(
- 'b2688adfc9e1009985dd1a41f41c15e7d5f1b50e'
+ '6940f91bc708e0d3c333d31c38cbfe51b3c0d927'
)
sha1sums_armv6h=(
- 'f9e017ebdefc7c57c170659a41ae8f54dadb8a43'
+ 'adf13c5e7c6dde7b91463fe5efbac8bd00d168f4'
)
sha1sums_armv7h=(
- 'f9e017ebdefc7c57c170659a41ae8f54dadb8a43'
+ 'adf13c5e7c6dde7b91463fe5efbac8bd00d168f4'
)
package() {
cd "$srcdir"
install -Dm 755 v2raya_v"${pkgver}" "${pkgdir}"/usr/bin/v2raya
- find web -type d -exec install -vd "${pkgdir}"/etc/v2raya/{} \;
- find web -type f -exec install -vm 644 {} "${pkgdir}"/etc/v2raya/{} \;
install -Dm 644 v2raya.desktop -t "${pkgdir}"/usr/share/applications/
install -Dm 644 v2raya.service -t "${pkgdir}"/usr/lib/systemd/system/
+ install -Dm 644 v2raya@.service -t "${pkgdir}"/usr/lib/systemd/system/
install -Dm 644 v2raya.png "${pkgdir}"/usr/share/icons/hicolor/512x512/apps/v2raya.png
}