summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormzz2022-09-21 19:16:15 +0800
committermzz2022-09-21 19:16:15 +0800
commit99ea53f24556ff91ea9928c41d8356580a69e57d (patch)
treef7b87142d816d6f083539b02286bf00ebefafce9 /PKGBUILD
parenta2f3f3d4784948c94b250ce39464423e4298619d (diff)
downloadaur-99ea53f24556ff91ea9928c41d8356580a69e57d.tar.gz
move v2ray dep into package func
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 69c980f1f3d9..a976e3308625 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="v2rayA nightly version"
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url="https://github.com/v2rayA/v2rayA"
license=('GPL3')
-depends=('glibc' 'v2ray>=5.0.0')
+depends=('glibc')
makedepends=('git' 'go>=2:1.16.0-1' 'nodejs>=14' 'yarn' 'python2')
provides=('v2raya')
conflicts=('v2raya')
@@ -36,6 +36,8 @@ build() {
}
package() {
+ depends+=('v2ray>=5.0.0')
+
cd "${srcdir}"/"${pkgname}"/
install -Dm 755 service/v2raya -t "${pkgdir}"/usr/bin/
install -dm 750 "${pkgdir}"/etc/v2raya/