summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoraksr2019-05-09 12:14:01 +0200
committeraksr2019-05-09 12:14:01 +0200
commitf6e05a73bb7692e984b11d7fc26928a2f4884f33 (patch)
tree0bf50577a82e98aa474331488a43a8c792a6ce3c /PKGBUILD
parentd9ba91b3611f151ea8f6bbe7e04f3850f12b8593 (diff)
downloadaur-v6shell-git.tar.gz
Update URL,...
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 44c18820f455..5042a31c9219 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: aksr <aksr at t-com dot me>
pkgname=v6shell-git
-pkgver=4.9.0.r14.g667288b
+pkgver=20100430.r33.g283c8b5
pkgrel=1
epoch=
pkgdesc="V6 Thompson Shell Port"
arch=('i686' 'x86_64')
url="http://v6shell.org/"
-url="https://github.com/JNeitzel/v6shell"
+url="https://github.com/quajo/v6shell.git"
license=('custom')
groups=()
depends=()
@@ -20,19 +20,17 @@ backup=()
options=()
changelog=
install=
-source=("$pkgname::git+https://github.com/JNeitzel/v6shell.git"
- "v6scripts::git+https://github.com/JNeitzel/v6scripts.git")
+source=("$pkgname::git+https://github.com/quajo/v6shell.git")
noextract=()
-md5sums=('SKIP' 'SKIP')
+md5sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
- git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/^v//'
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/^v//;s/^release.osh.//'
}
build() {
cd "$srcdir/$pkgname"
- ./configure
make
}
@@ -41,8 +39,8 @@ package() {
make DESTDIR="$pkgdir/" PREFIX=/usr install
install -Dm644 README $pkgdir/usr/share/doc/${pkgname%-*}/README
install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
- cd "$srcdir/v6scripts"
- mkdir -p "$pkgdir/usr/share/doc/${pkgname%-*}/scripts"
- cp -a * "$pkgdir/usr/share/doc/${pkgname%-*}/scripts"
+ cd "$srcdir/$pkgname/examples"
+ mkdir -p "$pkgdir/usr/share/doc/${pkgname%-*}/examples"
+ cp -a * "$pkgdir/usr/share/doc/${pkgname%-*}/examples"
}