summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarco Pompili2017-08-04 17:40:18 +0200
committerMarco Pompili2017-08-04 17:40:18 +0200
commitb0cba407a46e93c06fd70088c1c8498be8e9d971 (patch)
treea4bf842a66d65a9dab158f3bd445f14163108dba /PKGBUILD
parent3bd1540d3de247333eeebc5de5e1534f710da314 (diff)
downloadaur-b0cba407a46e93c06fd70088c1c8498be8e9d971.tar.gz
python venv fix for pacaur
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d8112d88c2ca..540e760a91e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -138,9 +138,13 @@ prepare() {
v8_enable_i18n_support=$V8_I18N_SUPPORT
v8_use_external_startup_data=\"$V8_USE_EXTERNAL_STARTUP_DATA\"
use_sysroot=$V8_USE_SYSROOT"
+
+ deactivate
}
build() {
+ source venv/bin/activate > /dev/null
+
cd v8
# Fixes bug in generate_shim_headers.py that fails to create these dirs
@@ -150,9 +154,13 @@ build() {
msg2 "Building, this will take a while..."
ninja -C $OUTFLD
+
+ deactivate
}
check() {
+ source venv/bin/activate > /dev/null
+
cd v8
msg2 "Testing, this will take also a while..."
@@ -161,6 +169,8 @@ check() {
--buildbot \
--arch=$V8_ARCH \
--mode=Release
+
+ deactivate
}
package() {