summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2019-04-17 12:29:28 +0200
committerPhilipp A2019-04-17 12:29:28 +0200
commit6f363f63061e2f48f3c31da4341293c783a0913b (patch)
treeab0bb4b667607d52452860412c93a42bdfb65c3d /PKGBUILD
parentd51146126aa64a2f92d02ad2982f03ef9ecc5ea2 (diff)
downloadaur-v8-3.14-bin.tar.gz
provide v8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 059852ba0619..7a20999a36fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: Franklyn Tackitt <franklyn@tackitt.net>
+# Maintainer: Philipp A. <flying-sheep@web.de>
+# Contributor: Franklyn Tackitt <franklyn@tackitt.net>
pkgname=v8-3.14-bin
pkgver=3.14.5.8
-pkgrel=3
+pkgrel=4
pkgdesc='v8 3.14 binary package from ubuntu xenial'
url='https://github.com/v8/v8'
arch=('x86_64')
license=('BSD')
depends=()
makedepends=()
-conflicts=('v8-3.14')
-provides=('v8-3.14')
+conflicts=('v8-3.14' 'v8')
+provides=('v8-3.14' 'v8')
source=("https://mirrors.kernel.org/ubuntu/pool/universe/libv/libv8-3.14/libv8-3.14.5_${pkgver}-5ubuntu2_amd64.deb"
"https://mirrors.kernel.org/ubuntu/pool/universe/libv/libv8-3.14/libv8-dev_${pkgver}-5ubuntu2_amd64.deb")
@@ -27,7 +28,7 @@ prepare() {
}
package() {
- install -Dm755 "${srcdir}/usr/lib/libv8.so.3.14.5" -t "${pkgdir}/usr/lib/"
+ install -Dm755 "${srcdir}/usr/lib/libv8.so"{,.3.14.5} -t "${pkgdir}/usr/lib/"
install -Dm644 "${srcdir}/usr/share/doc/libv8-dev/copyright" "${pkgdir}/usr/share/licenses/v8-3.14/LICENSE"
for file in "${srcdir}/usr/share/doc/libv8-dev/examples/"* "${srcdir}/usr/include/"*; do