summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaxor2018-10-23 02:55:32 +0300
committerhaxor2018-10-23 02:55:32 +0300
commit9e62ce078efcc6e9ae4b89f3bbc7b29038500ef6 (patch)
treedcd93f07fc7e984338501ecedea8af855d84e172 /PKGBUILD
parent2dd266e20e42a9ef68aca9be5eb84f05e2dcffbb (diff)
downloadaur-vacuum-im.tar.gz
PKGBUILD fixes:
* removed 'provides' and 'conflicts' entries; * set more unique name to source archive; * moved patching from build() to prepare(); * replaced tabs with spaces.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c32d1f6e033..478ed9560392 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,34 @@
pkgname=vacuum-im
pkgver=1.2.5
-pkgrel=2
+pkgrel=3
pkgdesc='Crossplatform Jabber/XMPP client'
arch=('i686' 'x86_64')
url="http://www.vacuum-im.org/"
license=('GPL3')
depends=('qt4' 'openssl' 'libidn' 'libxss' 'minizip')
makedepends=('cmake')
-provides=('vacuum-im' 'vacuum')
-conflicts=('vacuum-im-git' 'vacuum-svn')
-source=("https://github.com/Vacuum-IM/$pkgname/archive/$pkgver.tar.gz"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Vacuum-IM/$pkgname/archive/$pkgver.tar.gz"
"messagearchiver_build_fix.patch")
md5sums=('2004a882c95207b3244aadf77e822b9a'
'5815ef9480dd6ad94b78907d79642b5f')
sha256sums=('3237933f68884fb5b3422ad0fc97083b40a7aae9d8c105a23720c09599ffe5da'
'294e6639913e1d7495fb4729045683a3d61a20395d2de2de4204434c9a5050e7')
+prepare() {
+ cd $pkgname-$pkgver
+ patch -p0 --binary < ../messagearchiver_build_fix.patch
+}
+
build() {
- cd $pkgname-$pkgver
- patch -p0 --binary < ${srcdir}/messagearchiver_build_fix.patch
- mkdir build
- cd build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cd $pkgname-$pkgver
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make
}
package() {
- cd $pkgname-$pkgver/build
- make DESTDIR="$pkgdir/" install
+ cd $pkgname-$pkgver/build
+ make DESTDIR="$pkgdir/" install
}