summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2020-05-15 17:16:03 +0200
committerFabioLolix2020-05-15 17:16:03 +0200
commit896bbd8b29d66a0c549d7377d26f54d69d92c867 (patch)
tree1e0414351fcdd82d05b67d087316dd9248a01ee0 /PKGBUILD
parent1359117f8d5e6794ba2b8c4a09e3e445d168d74d (diff)
downloadaur-vala0.26.tar.gz
revision, intentionally removed provides vala for now
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 9 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72507807d9dc..e43ef90d04d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Brenton Horne <brentonhorne77 at gmail dot com>
+# Maintainer:
+# Contributor: Brenton Horne <brentonhorne77 at gmail dot com>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Timm Preetz <timm@preetz.us>
pkgname=vala0.26
-_pkgname=vala
pkgver=0.26.2
pkgrel=1
pkgdesc="Compiler for the GObject type system. Legacy version for building Valama against."
@@ -11,29 +11,19 @@ url="https://wiki.gnome.org/Projects/Vala"
arch=(i686 x86_64)
license=(LGPL)
depends=(glib2)
-provides=("vala=${pkgver}")
-conflicts=('vala')
-makedepends=(libxslt git vala)
-source=("git+https://github.com/GNOME/vala.git#tag=$pkgver")
-sha256sums=('SKIP')
-
-pkgver() {
- cd $_pkgname
- git describe --tags | sed 's/-/+/g'
-}
-
-prepare() {
- cd $_pkgname
- NOCONFIGURE=1 ./autogen.sh
-}
+#provides=(vala)
+conflicts=(vala)
+makedepends=(libxslt vala)
+source=("https://download.gnome.org/sources/vala/0.26/vala-${pkgver}.tar.xz")
+sha256sums=('37f13f430c56a93b6dac85239084681fd8f31c407d386809c43bc2f2836e03c4')
build() {
- cd $_pkgname
+ cd "vala-${pkgver}"
./configure --prefix=/usr --enable-vapigen
make
}
package() {
- cd $_pkgname
+ cd "vala-${pkgver}"
make DESTDIR="$pkgdir" install
}