summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdriĆ  Arrufat2016-11-28 20:05:38 +0100
committerAdriĆ  Arrufat2016-11-28 20:05:38 +0100
commit15bd3ff9809771871aa726e7a83eb46afa98536e (patch)
treeeebd7003cd4406859fbd4159258a5de3274e8360 /PKGBUILD
parent081d848c8ee1c0e6856e02d6495adade12218559 (diff)
downloadaur-15bd3ff9809771871aa726e7a83eb46afa98536e.tar.gz
Update to version 0.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 14 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf2ebcab7b27..b0bf6bd81b07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adria Arrufat <adria.arrufat+AUR@protonmail.ch>
# Contributor: Philipp Trommler <ph.trommler@gmail.com>
pkgname=valum
-pkgver=0.2.6+482+ga066e6d
+pkgver=0.3.0
pkgrel=1
pkgdesc="Web micro-framework written in Vala"
arch=("i686" "x86_64")
@@ -12,7 +12,7 @@ optdepends=("libmemcached: For memcached cache storage."
"memcached: For memcached cache storage."
"luajit: For an embedded Lua VM.")
makedepends=(git ninja vala meson)
-_commit=a066e6d40980aec02c9e1b5cadb931719541f0cc
+_commit=30c2b15f26cabbd62aa279deb88b652e43d05f0a
source=("git://github.com/antono/valum.git#commit=${_commit}")
md5sums=("SKIP")
@@ -25,7 +25,7 @@ build() {
cd ${pkgname}
[ -d build ] && rm -rf build
mkdir build && cd build
- meson ..
+ meson --prefix=${pkgdir}/usr ..
ninja
}
@@ -36,24 +36,22 @@ check() {
package() {
cd ${pkgname}/build
- DESTDIR=${pkgdir} ninja install
+ ninja install
# hack: place installation in /usr/ and not /usr/local
- cd ${pkgdir}
- for d in `ls usr/local`; do
- mv usr/local/$d usr/$d
- done
- mv usr/lib64 usr/lib
- rm -rf usr/local
- cd usr/lib/pkgconfig
- for f in `ls *pc`; do
- sed -i $f -e "s/\/local//g"
- done
+ # cd ${pkgdir}
+ # for d in `ls usr/local`; do
+ # mv usr/local/$d usr/$d
+ # done
+ # mv usr/lib64 usr/lib
+ # rm -rf usr/local
+ # cd usr/lib/pkgconfig
+ # for f in `ls *pc`; do
+ # sed -i $f -e "s/\/local//g"
+ # done
# end of hack
cd ${srcdir}/valum
- install -Dm644 examples/app/vapi/ctpl.vapi "${pkgdir}/usr/share/vala/vapi/"
- install -Dm644 src/vsgi/servers/fcgi.{deps,vapi} "${pkgdir}/usr/share/vala/vapi/"
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}