summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Lühne2020-11-25 21:30:55 +0100
committerPatrick Lühne2020-11-25 21:30:55 +0100
commit8642fdfd1009c880620396d634c5a5faac9f606e (patch)
treeddab93860fdfc965514fef7f4d8249d17ff939b0 /PKGBUILD
parent51cbd2f5dab38672f8de895c5996e275f52d2ba1 (diff)
downloadaur-8642fdfd1009c880620396d634c5a5faac9f606e.tar.gz
Update Vampire to 4.5
Vampire now supports building with CMake, so use that instead of the handwritten Makefile. The separate patch is used for two reasons. First, Vampire includes the current Git commit information in its --version output (commit hash and timestamp). When building this package from AUR, this would read the commit metadata from AUR and not the Vampire repository. Second, Vampire uses the __FILE__ macro even in release builds, which means that references to the build directory end up in the binary. To avoid this, a GCC- and Clang-specific compiler option is added to ensure that the file references are relative to Vampire’s source directory.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 17 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce5b398da4e6..165346e5276a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,34 @@
# Maintainer: Patrick Lühne <patrick-arch@luehne.de>
pkgname=vampire
-pkgver=4.4
+pkgver=4.5.1
+_commit_description='57a6f78c on 2020-07-15 11:59:04 +0200'
pkgrel=1
pkgdesc='A theorem prover for first-order logic'
arch=('x86_64')
url='https://vprover.github.io/'
license=('custom:Vampire Software Licence Agreement')
-source=("https://github.com/vprover/${pkgname}/archive/${pkgver}.tar.gz")
-sha512sums=('774452836e4cc6b7f2bcffc581b2fec0f15574adb58b4ab9fb3c771392aee2d34073129b8be32d73927f6613e83785e5d3d2ab161fe4eb09a039a0dee983a31a')
+depends=('z3')
+source=("https://github.com/vprover/${pkgname}/archive/${pkgver}.tar.gz"
+ 'reproducible-builds.patch')
+sha512sums=('dada4d91d96cdfe7a0f345f64d3c0e5ce2c909965cb8a90fd25d12ff4a8ee61e02b473d2e0054d90ae2930f5606728ff6b51ceb780c7ae1f5b35925f3b10fae4'
+ '894f739b84a006bce1e59109776b00ced190fc2cc30abedde2d5a50e6654efe63607d04c9815c780fddfc02a2cf0821afd558307f7e89f7bae9dbbfb52411b94')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch --forward --strip=1 --input="${srcdir}/reproducible-builds.patch"
+}
build() {
cd "${pkgname}-${pkgver}"
- make vampire_rel BRANCH= COM_CNT=
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_BUILD_TYPE=Release -DZ3_DIR=/usr/lib/cmake/z3/ -DVAMPIRE_AUR_GIT_COMMIT_DESCRIPTION="${_commit_description}"
+ make
}
package() {
cd "${pkgname}-${pkgver}"
- install -D "${pkgname}_rel__" "${pkgdir}/usr/bin/${pkgname}"
+ install -D "build/bin/${pkgname}" -t "${pkgdir}/usr/bin/"
install -D -m644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
install -D -m644 LICENCE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}