summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072019-03-02 20:52:21 +0100
committersL1pKn072019-03-02 20:52:21 +0100
commit2c277a9e60016885971cb0f09afb81a72f1960a4 (patch)
tree9018919f009c8ebfb52db1f9f1a26fb4306ea515 /PKGBUILD
parent045f836b965d0b1400ca13106b3d8b5aa2121410 (diff)
downloadaur-2c277a9e60016885971cb0f09afb81a72f1960a4.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8206c70ea8a6..abae33415e5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,13 +21,15 @@ pkgver() {
}
prepare() {
+ mkdir -p build
+
cd "${_plug}"
./autogen.sh
}
build() {
- cd "${_plug}"
- ./configure \
+ cd build
+ ../"${_plug}"/configure \
--prefix=/usr \
--libdir=/usr/lib/vapoursynth
@@ -35,8 +37,7 @@ build() {
}
package(){
- cd "${_plug}"
- make DESTDIR="${pkgdir}" install
+ make -C build DESTDIR="${pkgdir}" install
- install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.rst"
+ install -Dm644 "${_plug}/readme.rst" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.rst"
}