summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072022-03-13 02:24:58 +0100
committersL1pKn072022-03-13 02:24:58 +0100
commit3b443f9d62c58b51a3b254a1013bf7c3ce6e53a6 (patch)
tree194b5b4749b4efedb97e7eb2d223d860bfb94e15 /PKGBUILD
parent2c277a9e60016885971cb0f09afb81a72f1960a4 (diff)
downloadaur-3b443f9d62c58b51a3b254a1013bf7c3ce6e53a6.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index abae33415e5b..be499c8d05fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=bifrost
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v2.2.2.g3082823
+pkgver=2.2.2.g3082823
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -14,22 +14,23 @@ provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
}
prepare() {
mkdir -p build
+}
+build() {
cd "${_plug}"
./autogen.sh
-}
-build() {
- cd build
- ../"${_plug}"/configure \
+ cd "${srcdir}/build"
+ "../${_plug}/configure" \
--prefix=/usr \
--libdir=/usr/lib/vapoursynth