summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGustavo Alvarez2016-08-22 15:49:14 +0200
committerGustavo Alvarez2016-08-22 15:49:14 +0200
commitd42c7b7c44cb91ba14b3df7eaefd5411449ab2b5 (patch)
treefd0d40703409446f43a959468bb2773800c4149d /PKGBUILD
parenteb8bf0a26ed41af45b02d66bdee722bcb687a10c (diff)
downloadaur-d42c7b7c44cb91ba14b3df7eaefd5411449ab2b5.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 413d2071a77d..a821b2768580 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=bifrost
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v2.2.0.ga3c8d23
+pkgver=v2.2.2.g3082823
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
@@ -14,22 +14,27 @@ provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
sha1sums=('SKIP')
-_gitname="${_plug}"
pkgver() {
- cd "${_gitname}"
+ cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
-build() {
- cd "${_gitname}"
+prepare() {
+ cd "${_plug}"
./autogen.sh
- ./configure --prefix=/usr --libdir=/usr/lib/vapoursynth
+}
+
+build() {
+ cd "${_plug}"
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib/vapoursynth
make
}
package(){
- cd "${_gitname}"
+ cd "${_plug}"
make DESTDIR="${pkgdir}" install
- install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
+ install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.rst"
}