summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:32:34 +0200
committersl1pkn072015-06-08 20:32:34 +0200
commit8ec70f8c2bc3cb0e961b320ecc058431b2923acb (patch)
tree17f04b3525eb42f020160f49c6f924d331ef0407 /PKGBUILD
downloadaur-8ec70f8c2bc3cb0e961b320ecc058431b2923acb.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b0bd0f9665a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=bm3d
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r3.4.g8636c68
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url="http://forum.doom9.org/showthread.php?t=172172"
+license=('GPL')
+depends=('vapoursynth' 'fftw')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-BM3D.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+build() {
+ cd "${_plug}"
+ ./configure --install="${pkgdir}/usr/lib/vapoursynth"
+ make
+}
+
+package(){
+ cd "${_plug}"
+ make install
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}