summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072019-01-25 23:26:00 +0100
committersL1pKn072019-01-25 23:26:00 +0100
commit9804dd26284040f3860b75fde8cee3349a094be5 (patch)
tree907ddc2ec57065acfc94417eef43996d5b9f8d26 /PKGBUILD
parent1c55a58d8b44b515181c0f2d4df33c2e594a4831 (diff)
downloadaur-9804dd26284040f3860b75fde8cee3349a094be5.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae996e4a4807..d788bf6339e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=bm3d
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r6.0.gc955d0a
+pkgver=r8.0.g7b3d8dd
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
@@ -11,28 +11,33 @@ license=('MIT')
depends=('vapoursynth'
'fftw'
)
-makedepends=('git')
+makedepends=('git'
+ 'meson'
+ )
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-BM3D.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
+prepare() {
+ mkdir -p build
+}
+
build() {
- cd "${_plug}"
- ./configure \
- --install="${pkgdir}/usr/lib/vapoursynth" \
- --extra-cxxflags="${CXXFLAGS} ${CPPFLAGS}" \
- --extra-ldflags="${LDFLAGS}"
- make
+ cd build
+ arch-meson "../${_plug}" \
+ --libdir /usr/lib/vapoursynth
+
+ ninja
}
package(){
- cd "${_plug}"
- make install
- install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ DESTDIR="${pkgdir}" ninja -C build install
+
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}