summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072022-03-13 02:42:28 +0100
committersL1pKn072022-03-13 02:42:28 +0100
commit92c6fde7576168942e92e6bd85ccb21fdcc16799 (patch)
treeadcfe21aaf40d73b4661c78a3004759c32f8efd5 /PKGBUILD
parentbe2d4db9535c51499deba181caa55ab5092174ef (diff)
downloadaur-92c6fde7576168942e92e6bd85ccb21fdcc16799.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 522a8f143b3d..13c06dac9924 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=cnr2
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v1.2.g1f2c901
+pkgver=1.2.g1f2c901
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -14,22 +14,23 @@ provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
}
prepare() {
mkdir -p build
+}
+build() {
cd "${_plug}"
./autogen.sh
-}
-build() {
- cd build
- ../"${_plug}"/configure \
+ cd "${srcdir}/build"
+ "../${_plug}/configure" \
--prefix=/usr \
--libdir=/usr/lib/vapoursynth