summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072018-05-20 23:26:14 +0200
committersL1pKn072018-05-20 23:26:45 +0200
commit6fe5e6d61da2a9c58e82019cc7815a9851bd6874 (patch)
tree8e756efcd83a9eae438f946a187d4ef2c9104545 /PKGBUILD
parent4f9e2d98e90785fcdcd67ebb8692a3aba8ff09fe (diff)
downloadaur-6fe5e6d61da2a9c58e82019cc7815a9851bd6874.tar.gz
Fix build with ffmpeg4(?)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 19 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a94a7471e2a..29a0984fc816 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgver=v1.1.4.g5b5e587
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
-url="https://github.com/dwbuiten/${_plug}"
+url="https://forum.doom9.org/showthread.php?t=166399"
license=('LGPL2.1')
depends=('vapoursynth'
'libavutil.so'
@@ -16,8 +16,12 @@ depends=('vapoursynth'
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
-source=("git+https://github.com/dwbuiten/${_plug}.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/dwbuiten/${_plug}.git"
+ 'ffmpeg4.patch'
+ )
+sha256sums=('SKIP'
+ 'fe0cc3859a6e30e8bde4d79e78adbc5f315628cdfcc46abb9c38825674009183'
+ )
pkgver() {
cd "${_plug}"
@@ -25,22 +29,26 @@ pkgver() {
}
prepare() {
+ mkdir -p build
+
+ patch -d "${_plug}" -p1 -i "${srcdir}/ffmpeg4.patch"
+
cd "${_plug}"
./autogen.sh
-}
-build() {
- cd "${_plug}"
- ./configure \
+ cd ../build
+ ../"${_plug}"/configure \
--prefix=/usr \
--libdir=/usr/lib/vapoursynth
- make
+}
+
+build() {
+ make -C build
}
package(){
- cd "${_plug}"
- make DESTDIR="${pkgdir}" install
- install -Dm644 README "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
+ make -C build DESTDIR="${pkgdir}" install
+ install -Dm644 "${_plug}/README" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
}