summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072019-08-07 15:50:07 +0200
committersL1pKn072019-08-07 15:50:07 +0200
commit63a1a0f2f86d788735c9f7dd333e3bfc539011f5 (patch)
treea304ecb8c0b3f029edffb8d34be65b808a367849 /PKGBUILD
parenta0044bb03b1fa55a0da0e6d7252770e43e7e7d2d (diff)
downloadaur-63a1a0f2f86d788735c9f7dd333e3bfc539011f5.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e01a0ac6e0e0..07262d133f49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=dfttest
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r4.1.0.g7184c67
+pkgver=r6.0.g8d85dd8
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -11,7 +11,9 @@ license=('GPL')
depends=('vapoursynth'
'fftw'
)
-makedepends=('git')
+makedepends=('git'
+ 'meson'
+ )
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-DFTTest.git")
@@ -24,22 +26,18 @@ pkgver() {
prepare() {
mkdir -p build
-
- cd "${_plug}"
- ./autogen.sh
}
build() {
cd build
- ../"${_plug}"/configure \
- --prefix=/usr \
- --libdir=/usr/lib/vapoursynth
+ arch-meson "../${_plug}" \
+ --libdir /usr/lib/vapoursynth
- make
+ ninja
}
package(){
- make -C build DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja -C build install
install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}