summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072023-02-15 00:39:53 +0100
committersL1pKn072023-02-15 00:39:53 +0100
commit364d7ed5fcb652ab879cb9167b96095d5ac6ee5b (patch)
tree61912fbcc6db1cbfc1f436100a9556408c959547 /PKGBUILD
parentcfa835b869b77f5feffc507fdfb378f5e9dcc4f8 (diff)
downloadaur-vapoursynth-plugin-fftspectrum-git.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb927ba1769f..482be38a9391 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
_plug=fftspectrum
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r1.5.g6326b2e
+pkgver=1.5.g6326b2e
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -18,10 +18,11 @@ provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/Beatrice-Raws/FFTSpectrum.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d r)"
}
prepare() {
@@ -30,6 +31,7 @@ prepare() {
build() {
cd build
+ export CFLAGS="${CFLAGS/-march=x86-64 -mtune=generic/-march=native}"
arch-meson "../${_plug}" \
--libdir /usr/lib/vapoursynth