summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGustavo Alvarez2016-10-19 22:57:40 +0200
committerGustavo Alvarez2016-10-19 22:57:40 +0200
commitc8f68c4f76a38d849feeb2c84df25ecb6169530f (patch)
tree2db05a57ce2f613d70b43f9de8732e9a1dd12811 /PKGBUILD
parent8ede5e6ad5f270041faad1666dbdaee356a6262c (diff)
downloadaur-c8f68c4f76a38d849feeb2c84df25ecb6169530f.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c7631a95451..937ca909ee19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=finedehalo
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r1
+pkgver=r3
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('any')
@@ -16,9 +16,9 @@ provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}"
'vapoursynth-plugin-resamplehq-git')
source=("${_plug}::git+https://gist.github.com/bcd427ec0fa8fdf7c45433917521bac4.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
-_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
pkgver() {
cd "${_plug}"
@@ -26,5 +26,7 @@ pkgver() {
}
package() {
- install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_sites_packages}/${_plug}.py"
+ install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
}