summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsl1pkn072015-09-25 17:47:58 +0200
committersl1pkn072015-09-25 17:47:58 +0200
commit29eede8c482c5c60ed1c38263bd4398eab9dbdd3 (patch)
tree4d092fe32ff73174f1af412945f30a3ca5e8015a /PKGBUILD
parent602ae42f40f7096608cdf50e2933fabbfe2e79a8 (diff)
downloadaur-29eede8c482c5c60ed1c38263bd4398eab9dbdd3.tar.gz
Update PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f30b5ad81117..ae540d1e59c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
_plug=genericfilters
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=20140415.4eede12
+pkgver=r131.de02ff0
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
-url="http://forum.doom9.org/showthread.php?p=1656901#post1656901"
+url='http://forum.doom9.org/showthread.php?p=1656901#post1656901'
license=('LGPL2.1')
depends=('vapoursynth')
makedepends=('git')
@@ -17,7 +17,8 @@ sha1sums=('SKIP')
pkgver() {
cd "${_plug}"
- echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git log -1 --format="%h")"
+ #echo "$(git describe --long --tags | tr - .)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
@@ -26,8 +27,9 @@ prepare() {
build() {
cd "${_plug}/src"
- ./configure --install="${pkgdir}/usr/lib/vapoursynth" --extra-cflags="$(pkg-config --cflags vapoursynth)"
- make
+ ./configure --install="${pkgdir}/usr/lib/vapoursynth" \
+ --extra-cflags="${CFLAGS} $(pkg-config --cflags vapoursynth)" \
+ --extra-ldflags="${LDFLAGS}"
}
package(){