summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYamashita Ren2016-02-29 23:43:48 +0100
committerYamashita Ren2016-02-29 23:43:48 +0100
commitf5dc6abd3b651b6fdc7052e107f81edb717b1ba8 (patch)
tree6150ea52b26b5dffd580d1903ffb0eb080866a7a /PKGBUILD
downloadaur-f5dc6abd3b651b6fdc7052e107f81edb717b1ba8.tar.gz
Initial import.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac2fe8ff96bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Yamashita Ren
+# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=havsfunc
+pkgname=vapoursynth-plugin-${_plug}-light-git
+pkgver=r22.2.gf6fe61e
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug}. (Light depends, GIT version)"
+arch=('any')
+url='http://forum.doom9.org/showthread.php?t=166582'
+license=('GPL')
+optdepends=('vapoursynth-plugin-addgrain-git'
+ 'vapoursynth-plugin-awarpsharp2-git'
+ 'vapoursynth-plugin-bilateral-git'
+ 'vapoursynth-plugin-ctmf-git'
+ 'vapoursynth-plugin-dctfilter-git'
+ 'vapoursynth-plugin-deblock-git'
+ 'vapoursynth-plugin-dfttest-git'
+ 'vapoursynth-plugin-eedi2-git'
+ 'vapoursynth-plugin-fft3dfilter-git'
+ 'vapoursynth-plugin-flash3kyuu_deband-git'
+ 'vapoursynth-plugin-fluxsmooth'
+ 'vapoursynth-plugin-fmtconv'
+ 'vapoursynth-plugin-genericfilters-git'
+ 'vapoursynth-plugin-knlmeanscl'
+ 'vapoursynth-plugin-mvtools'
+ 'vapoursynth-plugin-nnedi3-git'
+ 'vapoursynth-plugin-sangnommod-git'
+ 'vapoursynth-plugin-scenechange'
+ 'vapoursynth-plugin-temporalsoften-git'
+ )
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}" "vapoursynth-plugin-${_plug}-git")
+source=("git+https://github.com/HomeOfVapourSynthEvolution/havsfunc.git")
+sha1sums=('SKIP')
+
+_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+package() {
+ install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_sites_packages}/${_plug}.py"
+}