summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072019-01-26 00:47:22 +0100
committersL1pKn072019-01-26 00:48:16 +0100
commit3ca64e3ade34ea82c9974650cc0bf258fea614a5 (patch)
treebcd815954ecbeafd7eeca2fac4db6c1b121c6387 /PKGBUILD
parentb4266c273f0f4c9d6287f2b2b8e63d0f9cb7653c (diff)
downloadaur-3ca64e3ade34ea82c9974650cc0bf258fea614a5.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a26733f49b48..466a65323822 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,12 +12,8 @@ depends=('vapoursynth'
'opencv'
)
makedepends=('git')
-source=("${_plug}::git+https://github.com/invisiblearts/VapourSynth-Inpaint.git"
- 'patch.patch'
- )
-sha256sums=('SKIP'
- 'f2454d793377b7f6a955d2f939dd83be7005a91025bfdca3b6867e49c172cd1c'
- )
+source=("${_plug}::git+https://github.com/invisiblearts/VapourSynth-Inpaint.git")
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
@@ -29,10 +25,11 @@ prepare(){
cd "${_plug}"
rm -fr VSHelper.h VapourSynth.h
- patch -p1 -i "${srcdir}/patch.patch"
+ sed 's|<vapoursynth.h>|<VapourSynth.h>|g' \
+ -i Inpaint.h
echo "all:
- g++ -c -std=gnu++11 -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o Inpaint.o Inpaint.cpp
+ g++ -c -std=gnu++11 -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) $(pkg-config --cflags opencv4) -o Inpaint.o Inpaint.cpp
g++ -shared -fPIC ${LDFLAGS} -o lib${_plug}.so Inpaint.o" > Makefile
}