summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072022-10-01 20:23:17 +0200
committersL1pKn072022-10-01 20:23:17 +0200
commitd2d7f807577b1a69100e965d1abc98c5e888acaf (patch)
treefb671c3105532706a2d6bbdea70d3bbb0f2dbb51 /PKGBUILD
downloadaur-d2d7f807577b1a69100e965d1abc98c5e888acaf.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c61cce8ab90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=jvsfunc
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=4.4.0.1.gf44039e
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='https://github.com/dnjulek/jvsfunc.git'
+license=('GPL')
+depends=('vapoursynth-plugin-vsutil-git'
+ 'vapoursynth-plugin-lvsfunc-git'
+ 'vapoursynth-plugin-vs-rgtools-git'
+ )
+makedepends=('git'
+ 'python-pip'
+ )
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/rlaPHOENiX/pvsfunc.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
+}
+
+build() {
+ cd "${_plug}"
+ pip wheel --no-deps . -w dist
+}
+
+package() {
+ cd "${_plug}"
+ pip install -I --root "${pkgdir}" --no-warn-script-location --no-deps dist/*.whl
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}