summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072019-04-14 22:01:29 +0200
committersL1pKn072019-04-14 22:02:36 +0200
commitaff79889d59dd9377fdc84f820e62fe697852270 (patch)
treefe25bded7dc58209a962efff8c29b90394cad7c8 /PKGBUILD
parent011c240f1533227e497553f751e11518d6adbe0e (diff)
downloadaur-aff79889d59dd9377fdc84f820e62fe697852270.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9f564636b70a..27b6d349d966 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,8 +20,12 @@ makedepends=('git'
)
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
-source=("${_plug}::git+https://github.com/VFR-maniac/L-SMASH-Works.git")
-sha256sums=('SKIP')
+source=("${_plug}::git+https://github.com/VFR-maniac/L-SMASH-Works.git"
+ 'patch.patch'
+ )
+sha256sums=('SKIP'
+ 'cb9603da5bd264ae5a1917490069d5dd564714bc0bd8aa5c46ad5b7f269170e1'
+ )
pkgver() {
cd "${_plug}"
@@ -33,6 +37,8 @@ prepare() {
cd "${_plug}"
rm -fr VapourSynth/VapourSynth.h
+
+ patch --binary -p1 -i "${srcdir}/patch.patch"
}
build() {
@@ -42,7 +48,7 @@ build() {
--extra-cflags="${CFLAGS} ${CPPFLAGS} $(pkg-config --cflags vapoursynth)" \
--extra-ldflags="${LDFLAGS}"
- make
+ LC_ALL=C make
}
package(){