summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGustavo Alvarez2016-10-19 22:07:35 +0200
committerGustavo Alvarez2016-10-19 22:07:35 +0200
commitaaded8c1afb17bd308190ab6de0cb32c621e6123 (patch)
tree710d623be7ac7a93cc78d7b796d5344719bc3574 /PKGBUILD
parent93c778d86ce87e7560c9568fdb9aca2450d599fd (diff)
downloadaur-aaded8c1afb17bd308190ab6de0cb32c621e6123.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 425a973f6b6f..a6915365d554 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=mvsfunc
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v5.r29.1e20b50
+pkgver=v9.r48.413e23f
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
@@ -15,9 +15,9 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/mvsfunc.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
-_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
pkgver() {
cd "${_plug}"
@@ -27,5 +27,7 @@ pkgver() {
package() {
cd "${_plug}"
- install -Dm644 "${_plug}.py" "${pkgdir}${_sites_packages}/${_plug}.py"
+ install -Dm644 "${_plug}.py" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_sites_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_sites_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
}