summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsl1pkn072015-10-13 16:00:22 +0200
committersl1pkn072015-10-13 16:00:22 +0200
commitdfb3607f28840352dad03bc7a69233589ad1cb0f (patch)
tree00064d397fc63583eb917abfb9c9828238563de4 /PKGBUILD
downloadaur-dfb3607f28840352dad03bc7a69233589ad1cb0f.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5baa86773b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=mvtools_sf
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=test12.2.gfb08881
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url='http://forum.doom9.org/showthread.php?t=172525'
+license=('GPL')
+depends=('vapoursynth'
+ 'fftw'
+ )
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/IFeelBloated/MVTools_SF.git")
+sha1sums=('SKIP')
+
+_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ cd "${_plug}"
+ ./autogen.sh
+}
+
+build() {
+ cd "${_plug}"
+ ./configure --prefix=/usr \
+ --libdir=/usr/lib/vapoursynth
+ make
+}
+
+package(){
+ cd "${_plug}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 src/mvmulti.py "${pkgdir}${_sites_packages}/mvmulti.py"
+}