summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072019-03-02 20:58:54 +0100
committersL1pKn072019-03-02 20:58:54 +0100
commit28ed48736861f405d2f69bb3b582c0050088ec9d (patch)
treed4b7cf356efb8ae78cd922e50988d50bb6fa3aea /PKGBUILD
parentc86056d1942616a84d68e07349353f73eb68871f (diff)
downloadaur-28ed48736861f405d2f69bb3b582c0050088ec9d.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6fe3dd540175..7fcc319b92b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
_plug=sangnom
pkgname=vapoursynth-plugin-${_plug}-hg
-pkgver=36.24bf165026c6
+pkgver=40.5a00bb64258d
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (HG version)"
-arch=('i686' 'x86_64')
-url='http://forum.doom9.org/showthread.php?t=173752'
+arch=('x86_64')
+url='https://forum.doom9.org/showthread.php?t=173752'
license=('MIT')
depends=('vapoursynth')
makedepends=('mercurial')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::hg+https://bitbucket.org/James1201/vapoursynth-sangnom")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
@@ -21,21 +21,25 @@ pkgver() {
}
prepare() {
+ mkdir -p build
+
cd "${_plug}"
chmod +x autogen.sh
./autogen.sh
}
build() {
- cd "${_plug}"
- ./configure \
+ cd build
+ ../"${_plug}"/configure \
--libdir="/usr/lib/vapoursynth"
+
make
}
package(){
- cd "${_plug}"
- make DESTDIR="${pkgdir}" install
- install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ make -C build DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ install -Dm644 "${_plug}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}