summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGustavo Alvarez2016-08-06 16:53:16 +0200
committerGustavo Alvarez2016-08-06 16:53:16 +0200
commit40cf1a6b42d9ae60038aa620711b92eb35b994f4 (patch)
tree994085d75f13182f798b50c324030271e716eae9 /PKGBUILD
downloadaur-40cf1a6b42d9ae60038aa620711b92eb35b994f4.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8c41c20ec83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=sangnom
+pkgname=vapoursynth-plugin-${_plug}-hg
+pkgver=18.c4e2a8681c27
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (HG version)"
+arch=('i686' 'x86_64')
+url='http://forum.doom9.org/showthread.php?t=173752'
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('mercurial')
+provides=("vapoursynth-plugin-${_plug}"
+ 'vapoursynth-plugin-sangnommod'
+ 'vapoursynth-plugin-sangnommod-git'
+ )
+conflicts=("vapoursynth-plugin-${_plug}"
+ 'vapoursynth-plugin-sangnommod'
+ 'vapoursynth-plugin-sangnommod-git'
+ )
+source=("${_plug}::hg+https://sl1pkn07@bitbucket.org/James1201/vapoursynth-sangnom")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(hg log -r -1 --template '{rev}.{node|short}\n')"
+}
+
+prepare() {
+ cd "${_plug}"
+ echo "all:
+ g++ -o lib${_plug}.so -std=gnu++11 -msse4.1 ${CXXFLAGS} ${CPPFLAGS} ${LDFLAGS} $(pkg-config --cflags vapoursynth) sangnom_c.cpp -shared -fPIC" > Makefile
+}
+
+build() {
+ make -C "${_plug}"
+}
+
+package(){
+ cd "${_plug}"
+ install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}