summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072019-03-02 20:59:27 +0100
committersL1pKn072019-03-02 20:59:27 +0100
commit95498391dd9758961080521879bf5c7316181f77 (patch)
tree6d92480b42fe549a37d5126877eeaeca65a40284 /PKGBUILD
parente73f0a240984bb3b85647a2be124dbfa07babb4f (diff)
downloadaur-95498391dd9758961080521879bf5c7316181f77.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6697f398ce10..86ae5d756c3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=vapoursynth-plugin-${_plug}-git
pkgver=v1.0.1.g30b3a47
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/dubhater/vapoursynth-${_plug}"
license=('GPL')
depends=('vapoursynth')
@@ -13,7 +13,7 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
@@ -21,18 +21,23 @@ pkgver() {
}
prepare() {
+ mkdir -p build
+
cd "${_plug}"
./autogen.sh
}
build() {
- cd "${_plug}"
- ./configure --libdir=/usr/lib/vapoursynth
+ cd build
+ ../"${_plug}"/configure \
+ --prefix=/usr \
+ --libdir=/usr/lib/vapoursynth
+
make
}
package(){
- cd "${_plug}"
- make DESTDIR="${pkgdir}" install
- install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
+ make -C build DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${_plug}/readme.rst" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
}